Resolved
We have increased the capacity of our integrations API, and it is now fulfilling all its requests.
Identified
To handle the increased traffic, we are going to increase our capacity.
Investigating
We are experiencing increased load to our integrations API, causing some requests to fail and slowing down responses in general. Impact began at 10:00 UTC